The new 2.6.31-rc4-rt1 patch annotates spinlocks which can not be converted to sleeping "spinlocks" as atomic_spinlock_t. The name is not perfect and we are looking for a better one which avoids the atomic confusion and expresses the fact that this lock always spins and disables preemption as well.
Please add your suggestions to the list below.
|atomic_spinlock||the current name, confusing vs. the atomic* APIs|
|real_spinlock||self explaining, but sucks|
|hard_spinlock||close, but sucks more|
|preemption_disabling_never_sleeping_spinlock||way tooo long|
|vanilla_spinlock||self explaining...but don't know if it is any better. :)|
|pure_spinlock||sucks more than hard_spinlock?|
|indivisible_spinlock||sucks more than hard_spinlock?|
|nonrt_spinlock||inimicle to RT, better than evil_spinlock?|
|ondine_spinlock||not self explaining, a bit of mythology?|
|spinning_lock||same concept, easy identification|
|nuclear_spinlock||more indivisible than atomic|
|insomniac_spinlock||No geek slang|
If we pick one of the suggested names based on its accuracy and obviousness the inventor can expect free beer at a FOSS conference where ( tglx) happens to be there as well.